Cheapest Palindrome 来自(POJ 3280) (区间dp)

Cheapest Palindrome

Time Limit: 2000MS

Memory Limit: 65536K

Total Submissions: 7343

Accepted: 3544

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:有一个长度为m的字符串,由n种小写字母组成。对应的n种字母在这个字符串加上或者减去都有相应的费用,现在要将这个字符串变成回文串,问最低消费是多少?

题解:区间dp,不会啦。又看题解了(;′⌒`)!我们用dp[i][j]表示将i~j位置的字符串变为回文串的最低消费。

可得以下递推关系:

当str[i]==str[j]时:dp[j][i]==dp[j+1][i-1]

当i+1到j是回文串时:dp[j][i]==dp[j+1][i] + num[s[j]-'a']

当i到j-1是回文串时:dp[i][j]==dp[i][j-1] + num[s[i]-'a']

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<queue>
#define N 0x3f3f3f3f
using namespace std;
int num[2020];
int dp[2020][2020];
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
	int a,b;
	char c;
	string s;
	cin>>s; 
	for(int i=1;i<=n;i++)
	{
		cin>>c>>a>>b;
		num[c-'a']=min(a,b);// 因为添加和删除是一样的效果 所以找到最小的即可 
	}	
	for(int i=1;i<m;i++)
	{
		for(int j=i-1;j>=0;j--)
		{
			dp[j][i]=min(dp[j+1][i]+num[s[j]-'a'],dp[j][i-1]+num[s[i]-'a']);
			if(s[i]==s[j])
			dp[j][i]=dp[j+1][i-1];
		}
		
	}
	cout<<dp[0][m-1]<<endl; 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81154160