POJ 3280 Cheapest Palindrome (区间dp)

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:

         就是一串字符串求它变成回文字符串的最小花费,每个字符都有它的添加和删去需要的花费

思路:

        就是按照区间dp的思路,先求小区间的最优解,再在大区间中用小区间求出大区间的最优解

例如一个字符串 a b f d e f g

                    i:    0 1 2 3 4 5 6

先从后面从小到大依次便遍历,

先是从 g - 空  dp[6][0-6] = 0

然后是 f - g  因为f != g 

        这时只对单个字符操作,所以他们如果想成为一个回文字符串的话,

剪掉f 或者 fgf ,(这是对f操作)就是操作掉f后从i + 1 到j 为一个回文字符串 

剪掉g 成为f 或者在加上一个g成为 gfg(这是对g操作)操作掉g后从i 到 j - 1 为一个回文字符串

这四种情况,所需的花费dp[5][6] = min(dp[6][6] + cost[s[i]] , dp[5][5] + cost [s[j]]);

而从 e - g 则是

e != f 同上 操作,然后是 e != g  这是操作e 或 g ,操作后的子字符串所处于回文串的最小代价加上所要消耗的cost。dp[4][6] = min (dp[4 + 1][6] + mm[ss[i]], dp[4][6 - 1] + mm[ss[j]]);

而f - f这种情况,那么这个子字符串的头和尾已经是回文了,那么它的最小代价就等于dp[2][5] = dp[3][4],等于它的子字符串的最小消耗

AC代码:

#include <iostream>
#include <map>
#include <string.h>
#include <string>
#include <algorithm>
using namespace std;

const int maxx = 2000 + 5;
int dp[maxx][maxx];

int main(int argc, const char * argv[]) {
    map<char, int> mm;
    int n, m;
    cin >> n >> m;
    string ss;
    cin >> ss;
    for (int i = 0; i < n; i ++) {
        char m;
        int xin, xout;
        cin >> m >> xin >> xout;
        mm[m] = min(xin, xout);
    }
    memset(dp, 0, sizeof(dp));
    for (int i = m - 1; i >= 0; i --) {
        for (int j = i + 1; j < m; j ++) {
            if (ss[i] == ss[j]) {
                dp[i][j] = dp[i + 1][j - 1];
            }else{
                dp[i][j] = min (dp[i + 1][j] + mm[ss[i]], dp[i][j - 1] + mm[ss[j]]);
            }
        }
    }

    cout << dp[0][m - 1] << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/henu_jizhideqingwa/article/details/81078295