POJ3280 Cheapest Palindrome(区间DP)

POJ3280 Cheapest Palindrome(区间DP)

Description
Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).
Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).
FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.
Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.
Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800
Sample Output
900

题意

对给定的一串字符串进行插入或者删除,使其变成回文串。题目给出了字符增加或者删去需要花费的值,问我们如何增删能使花费的值最小。区间[i+1,j]到区间[i,j]的增删的操作如下
在这里插入图片描述
区间[i,j-1]到区间[i,j]同理。
由此可见,删去字符和增加字符的情况实际上是一样的,所以我们只需要在这两个操作里取花费最小的即可。

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<functional> 
#include<map>
using namespace std;
typedef long long ll;
const int N=1e6+10,NN=2e3+10,INF=0x3f3f3f3f;
const ll MOD=1e9+7;
int n,m,len; 
int v[N];
int dp[NN][NN];//表示区间[i,j]变成回文串需要花费的值 
char str[NN];
void init(){
	for(int i=1;i<=len;i++){
		for(int j=i;j<=len;j++){
			if(i==j) dp[i][j]=0;//单个字符就是一个回文串,不需要增删
			else dp[i][j]=INF;
		}
	}
}
int main(){
	scanf("%d%d",&n,&m);
	scanf("%s",str+1);
	len=strlen(str+1);
	init();
	for(int i=1;i<=n;i++){
		char ch;
		int pushvalue,popvalue;
		scanf(" %c %d %d",&ch,&pushvalue,&popvalue);
		v[ch-'a']=min(pushvalue,popvalue);//取两种操作花费的最小值
	}
	for(int i=len;i>=1;i--){//i是区间起点 
		for(int j=i+1;j<=len;j++){//j是区间终点 
			if(str[i]==str[j]) dp[i][j]=dp[i+1][j-1];//如果区间起点与区间终点相同,则不需要增删
			else dp[i][j]=min(dp[i][j-1]+v[str[j]-'a'],dp[i+1][j]+v[str[i]-'a']);//取两种情况的最小值
		}
	}
	printf("%d\n",dp[1][len]);
}

猜你喜欢

转载自blog.csdn.net/Hc_Soap/article/details/107529548