【ACM】【DFS】【水】Lake Counting

版权声明:转载请注明出处~~~ https://blog.csdn.net/lesileqin/article/details/89043721

Lake Counting

点我前往题目页面

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 49820   Accepted: 24452

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

USACO 2004 November

题目大意:

最近总是下雨、约翰想统计院子里面有多少处连着的水洼," W "代表水洼、" . "代表陆地,W只要连着就行,就是一个大水洼。题目要求统计共有几个大水洼。

解题思路:

遍历整个图,只要遇到“ W ”就深搜,八个方向遇到“ W ”就变成“ . ”,运行几次深搜,就是题目的答案。

AC代码如下:

#include<iostream>

using namespace std;

//W .
int N,M;
//N行M列 
char mapp[101][101];
int nextt[8][2]={{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};

void dfs(int x,int y)
{
	mapp[x][y]='.';
	for(int i=0;i<8;i++)
	{
		int gx=x+nextt[i][0];
		int gy=y+nextt[i][1];
		if(gx>=0&&gx<N&&gy>=0&&gy<M&&mapp[gx][gy]=='W')
			dfs(gx,gy);
	}	
}

int main()
{
	int ans=0;
	cin >> N >> M;
	for(int i=0;i<N;i++)
		for(int j=0;j<M;j++)
			cin >> mapp[i][j];
	for(int i=0;i<N;i++)
	{
		for(int j=0;j<M;j++)
		{
			if(mapp[i][j]=='W')
			{
				dfs(i,j);
				ans++;
			}
		}
	}
	cout << ans << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lesileqin/article/details/89043721