深搜(dfs) —— Lake Counting 积水问题

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 
Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
0 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

C++:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
int N,M;
char p[1010][1010];
void dfs(int x,int y)
{
    int dx=-1;int dy=-1;
    p[x][y]='.';
    for(dx=-1;dx<=1;dx++)
    {
        for(dy=-1;dy<=1;dy++)
        {
            int xx=x+dx,yy=y+dy;
            if(0<=xx&&xx<N&&0<=yy&&yy<M&&p[xx][yy]=='W')
                dfs(xx,yy);
        }
    }
    return ;
}
int main()
{
    int i,j,res;
    res=0;
    scanf("%d%d",&N,&M);
    getchar();
    for(i=0;i<N;i++)
    {
        for(j=0;j<M;j++)
        {
            scanf("%c",&p[i][j]);
        }
        getchar();
    }
    for(i=0;i<N;i++)
    {
        for(j=0;j<M;j++)
        {
            if(p[i][j]=='W')
            {
                dfs(i,j);
                res++;
            }
        }
    }
    printf("%d\n",res);
    return 0;
}


Java:

import java.util.*;
import java.math.*;
public class Main 
{
	static int n, m, sum;
	static char[][]mapp = new char[105][105];
	public static void main(String[] args) 
	{
		// TODO Auto-generated method stub
		Scanner cin = new Scanner (System.in);
		while(cin.hasNext())
		{
			n = cin.nextInt();
			m = cin.nextInt();
			String s;
			for(int i=1; i<=n; i++)
			{
				s = cin.next();
				for(int j=1; j<=m; j++)
				{
					mapp[i][j] = s.charAt(j-1);
				}
			}
			solve();
			System.out.println(sum);
		}
	}
	private static void solve()
	{
		sum = 0;
		for(int i=1; i<=n; i++)
		{
			for(int j=1; j<=m; j++)
			{
				if(mapp[i][j]=='W')
				{
					dfs(i,j);
					sum++;
				}
			}
		}
	}
	private static void dfs(int x, int y)
	{
		mapp[x][y]='.';
		for(int i=-1; i<=1; i++)
		{
			for(int j=-1; j<=1; j++)
			{
				int xx = x+i;
				int yy = y+j;
				if(xx>=1&&xx<=n&&yy>=1&&yy<=m&&mapp[xx][yy]=='W')
					dfs(xx, yy);
			}
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_42569807/article/details/87990826