DFS (Lake Counting)

Lake Counting

原题链接:http://poj.org/problem?id=2386

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.


Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

我所理解的题目意思和注意点:

没啥可说的,比较容易,直接上代码(挑战程序设计)。


#include<stdio.h>
#define MAX_N 100
#define MAX_M 100

int N,M,res;
char field[MAX_N][MAX_M];

int dfs(int x,int y)
{
    field[x][y]='.';

    for(int dx=-1;dx<=1;dx++){
        for(int dy=-1;dy<=1;dy++){
            int nx=x+dx;
            int ny=y+dy;
            if(0<=nx&&nx<N&&0<=ny&&ny<M&&field[nx][ny]=='W')
                dfs(nx,ny);
        }
    }
}

int main()
{
    scanf("%d%d",&N,&M);
    for(int i=0;i<N;i++)
        scanf("%s",field[i]);

    for(int i=0;i<N;i++){
        for(int j=0;j<M;j++){
            if(field[i][j]=='W'){
                dfs(i,j);
                res++;
            }
        }
    }
    printf("%d\n",res);
    return 0;
}

emm.......祝我国庆快乐。

猜你喜欢

转载自blog.csdn.net/LaoXiangQ/article/details/82918668