A - Lake Counting

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jingmin52296358al/article/details/52117067

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

#include<iostream>
using namespace std;

char map[101][101];
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}};
int n,m,num;
int dfs(int x,int y)
{
     int a,b,k;
     map[x][y]='.';
     for(k=0;k<8;++k)
     {
          a=x+dir[k][0];
          b=y+dir[k][1];
          if(a<n&&a>=0&&b<m&&b>=0&&map[a][b]=='W')
              dfs(a,b);
     }
     return 1;
}
int main()
{
    int i,j;
    while(cin>>n>>m)
    {
        num=0;
        for(i=0;i<n;++i)
            cin>>map[i];
        for(i=0;i<n;++i)
           for(j=0;j<m;++j)
               if(map[i][j]=='W')
                   num+=dfs(i,j);
        cout<<num<<endl;
    }
} 


猜你喜欢

转载自blog.csdn.net/jingmin52296358al/article/details/52117067