【POJ 2386 --- Lake Counting】DFS

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_41879343/article/details/102685215

【POJ 2386 --- Lake Counting】DFS


Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

解题思路

采用深度优先搜索,从任意的w开始,不断把邻接的部分用’.‘代替,1次DFS后与初始这个w连接的所有w就全都被替换成’.’,因此直到图中不再存在W为止,总共进行DFS的次数就是答案。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN = 105;
char str[MAXN][MAXN];
int n,m;
int dir[2][8]{ {-1,0,1,1,1,0,-1,-1},{1,1,1,0,-1,-1,-1,0} };

void dfs(int x,int y)
{
    str[x][y]='.';
    for(int i=0;i<8;i++)
    {
        int dx=x+dir[0][i];
        int dy=y+dir[1][i];
        if(dx>=0 && dy>=0 && dx<n && dy<m && str[dx][dy]=='W')
            dfs(dx,dy);
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
        scanf("%s",str[i]);
    int ans=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            if(str[i][j]=='W')
                dfs(i,j),ans++;
    cout << ans << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/102685215