【POJ 2386】Lake Counting 深搜DFS

                                          Lake Counting

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17917   Accepted: 9069

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
#include <iostream>
using namespace std;
int n,m;
char map[101][101];
void dfs(int x,int y)
{
    map[x][y]='.';
    for(int dx=-1;dx<=1;dx++)
    {
        for(int dy=-1;dy<=1;dy++)
        {
            int nx=dx+x,ny=dy+y;
            if(nx>=1&&nx<=n&&ny>=1&&ny<=m)
            {
                if(map[nx][ny]=='W')
                {
                    dfs(nx,ny);
                }
            }
        }
    }
}
int solve()
{
    int x=0;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if(map[i][j]=='W')
            {
                dfs(i,j);
                x++;
            }
        }
    }
    return x;
}
int main()
{
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            cin>>map[i][j];
        }
    }
    cout<<solve()<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xylon_/article/details/81141879