PAT A1038

  • 题目:
    Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
    Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

  • 题目大意
    给出一组数,求出这组数拼接出来的最小值

  • 分析
    贪心算法。让我们一起来见证cmp函数的强大之处!!~~不是按照字典序排列就可以的,必须保证两个字符串构成的数字是最小的才行,所以cmp函数写成return a + b < b + a;的形式,保证它排列按照能够组成的最小数字的形式排列。
    证明在:《算法笔记》P163页

代码实现:

#include <string>
#include <vector>
#include <algorithm>
#include <iostream>
#include <cstdio>
using namespace std;
bool cmp(string a, string b){              //若a+b < b+a 则a排在b前面
    return a + b < b + a;
}
int main(){
    int n;
    string res;
    scanf("%d", &n);
    vector <string> vec(n);
    for(int i = 0; i < n; i++){
        cin >> vec[i];
    }
    sort(vec.begin(), vec.end(), cmp);       //排序
    for(int i = 0; i < n; i++){
        res += vec[i];                     //得出答案
    }
    while(res.size() != 0 && res[0] == '0'){          //删除开头的0
        res.erase(res.begin());
    }
    if(res.size() == 0) cout << 0;
    cout  << res;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/89024400