7-11 树的遍历(25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2
#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;
struct node{
	int data;
	struct node *l,*r;
};
struct node *creat(int *a,int *b,int n)
{
	struct node *shu;
	shu=(struct node*)malloc(sizeof(struct node));
	if(n<=0)
	return NULL;
	int i;
	
	shu->data=a[n-1];
	for(i=0;i<n;i++)
	{
		if(b[i]==a[n-1])
		break;
	}
	shu->l=creat(a,b,i);
	shu->r=creat(a+i,b+i+1,n-i-1);
	return shu;
}
int flag=1;
void cengxu(struct node*L)
{
	struct node *p[1001];
	int in=0,out=0;
	p[in++]=L;
	while(in>out)
	{
		if(p[out]!=0)
		{
			if(flag)
			{
				printf("%d",p[out]->data);
				flag=0;
			}
			else
			printf(" %d",p[out]->data);
		p[in++]=p[out]->l;
		p[in++]=p[out]->r;	
		}
	
		out++;
	}
}
int main()
{
	int N,i;
	int a[50],b[50];
	struct node*shu;
	shu=(struct node *)malloc(sizeof(struct node));
	scanf("%d",&N);
	for(i=0;i<N;i++)
	{
		scanf("%d",&a[i]);
	}
	for(i=0;i<N;i++)
	{
		scanf("%d",&b[i]);
	}
	shu=creat(a,b,N);
	cengxu(shu);
	return 0;
}


给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N\le30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2


 #include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
int data;
struct node *l,*r;
};
struct node *creat(int *a,int *b,int n)
{
struct node *xulie;
if(n<=0)
{
return NULL;
}
xulie=(struct node *)malloc(sizeof(struct node));
xulie->data=a[0];//指向树的根节点
int q;
for(q=0;q<n;q++)
{
if(b[q]==a[0])//中 前
{
break;
}
}
xulie->l=creat(a+1,b,q);//前首地址 中首地址  节点数
xulie->r=creat(a+q+1,b+q+1,n-q-1);
return xulie;
}

int flag=1;
void cengxu(struct node *p)//层序遍历  一层一层输出
{
int in=0,out=0;
struct node *a[1050];
a[in++]=p;//根节点 相当于进队  进了一个 in=1 a[0]有值,a[1]无值
 
while(in>out)//out<=in表示队空 
{
if(a[out]!=NULL)
{
if(flag)
{
 
printf("%d",a[out]->data);//从a[0]开始输出
flag=0;//标记,只为格式
}
else
printf(" %d",a[out]->data);
a[in++]=a[out]->r;//根节点的右孩子进队
a[in++]=a[out]->l;
}
    out++;//一个个出队
}
}
int main()

{
int n,i;
scanf("%d",&n);
int a[110],b[110];
struct node *xulie;
xulie=(struct node *)malloc(sizeof(struct node));
for(i=0;i<n;i++)
{
scanf("%d",&b[i]);
}
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
xulie=creat(a,b,n);
cengxu(xulie);
printf("\n");
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39178993/article/details/79748991