POJ--3666 Making the Grade(dp)(数据有问题)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37868325/article/details/88558164

题意:

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

A 1 -  B 1| + |  A 2 -  B 2| + ... + |  AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

思路:

也是比较有趣的一个题,但是数据实在太弱,第一个点处理的时候,没考虑最低的情况也能A,,,有点迷。。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<set>
#include<cmath>
#include<map>
#include<vector>
#include<iomanip>
using namespace std;
typedef long long ll;
const int maxn=2000+5;
int T,n,m,k,dp[maxn][maxn],ans,a[maxn],b[maxn],c[maxn];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        b[i]=a[i];
    }
    sort(a+1,a+1+n);
    for(int i=1;i<=n;i++)
    dp[1][i]=abs(b[1]-a[i]);
    for(int i=2;i<=n;i++)
    {
        k=dp[i-1][1];
        for(int j=1;j<=n;j++)
        {
            k=min(k,dp[i-1][j]);
            dp[i][j]=k+abs(a[j]-b[i]);
            //cout<<i<<" "<<j<<" "<<k<<" "<<dp[i][j]<<endl;
        }
    }
    ans=dp[n][1];
    for(int i=1;i<=n;i++)
    {
        ans=min(ans,dp[n][i]);
    }
    printf("%d\n",ans);
}
/*
7

9 3 5 4 2 3 1
1 3 2 4 5 3 9
*/

猜你喜欢

转载自blog.csdn.net/qq_37868325/article/details/88558164