Dp-基础 Poj3666- Making the Grade

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A 1 - B 1| + | A 2 - B 2| + ... + | AN - BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9
Sample Output
 
 
3
思路:
因为求最小代价,所以每个数变换后只会变成以前出现的数。(题目要求非严格递增递减)
dp[i][j]表示前i项中以第j小项结尾的最小代价。
dp[i][j] = min ( dp[i-1][k] ) + abs( a[i] - b[k] ) k <= j , b 为a[]数组排序后的顺序数组。
3次循环会TE,那么用k记录到j的最小值,不断更新。

正着求一次非严格递增,倒着求一次非严格递增(即为正着的非严格递减),取两次的最小值即为答案。

Code:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int AX = 2e3+66;
int a[AX];
int b[AX];
int c[AX];
int dp[AX][AX];
int main(){
	int n ;
	scanf("%d",&n);
	for( int i = 1 ; i <= n ; i++ ){
		scanf("%d",&a[i]);
		b[i] = a[i];
		c[n-i+1] = a[i];
	}
	memset( dp , 0 , sizeof(dp) );
	sort( b + 1 , b + n + 1 );
	for( int i = 1 ; i <= n ; i++ ){ 
		int k = dp[i-1][1];
		for( int j = 1 ; j <= n ; j++ ){
			k = min( k , dp[i-1][j] );
			dp[i][j] = k + abs( a[i] - b[j] ) ;
		}
	}
	int res = INF;
	for( int i = 1 ; i <= n ; i++ ){
		res = min( res , dp[n][i] );
	}
	for( int i = 1 ; i <= n ; i++ ){
		int k = dp[i-1][1];
		for( int j = 1 ; j <= n ; j++ ){
			k = min( k , dp[i-1][j] );
			dp[i][j] = k + abs( c[i] - b[j] );
		}
	}
	for( int i = 1 ;  i <= n ; i++ ){
		res = min( res , dp[n][i] );
	}
	cout << res << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/frankax/article/details/80245376