HDU 6216(数学)

版权声明:这些都是咸鱼Nova最后的挣扎,各位大佬转载请注明出处 https://blog.csdn.net/weixin_40883049/article/details/79108387

A Cubic number and A Cubic Number

Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example,  3×3×3=27 so  27 is a cubic number. The first few cubic numbers are  1,8,27,64 and  125. Given an prime number  p. Check that if  p is a difference of two cubic numbers.
 

Input
The first of input contains an integer  T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number  p (2p1012).
 

Output
For each test case, output 'YES' if given  p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
 
   
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
 
   
NO NO NO YES NO NO NO YES NO NO

题意:给你一个质素,问这个质数是否可以等于两个立方和数的差,是输出yes,否则输出no。
心路历程:我们不妨设质数为p=x^3-y^3,由立方和公式得p=(x-y)(x^2+xy+y^2),由于p是质数,所以我们可得x-y等于1,
x^2+xy+y^2=p。两式联立得p=3x^2+3x+1=3x(x+1)+1。观察到p-1 是3得倍数,且(p-1)/3可以由两个连续的数的乘积,所以我们只需要判断p-1是否满足这两个条件即可(或者由p=3x^2+3x+1知x正半轴是单调的,可以用二分查找整数根,参考 大佬

ac代码如下:
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int ca;
    scanf("%d",&ca);
    while(ca--)
    {
        long long m;
        scanf("%lld",&m);
        if((m-1)%3!=0)//先判断m-1是否是3的倍数
        {
            printf("NO\n");
            continue;
        }
        long long tmp=(m-1)/3;
        long long s=sqrt(tmp);//可以证明若它可以被两个相邻整数的乘积所表示,那么它的平方根的整数部分一定是相邻数中小的那个
        if(s*(s+1)==tmp)printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/weixin_40883049/article/details/79108387