hdu4004-The Frog's Games

题目链接

                                     The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 10143    Accepted Submission(s): 4618

 

Problem Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output

For each case, output a integer standing for the frog's ability at least they should have.

 

Sample Input

6 1 2

2

25 3 3

11 2 18

Sample Output

4

11

 思路:简单二分,写的多的话,会处理的很好,如果写的少,那可能会跟我写的蠢代码一样。

先记录一下自己的WA代码:是真的蠢


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+5;
int a[maxn],k[maxn];
int l,m,n,smax,smin,funny;
int func()
{
	smax=-9999999;
	for(int i=0;i<=n;i++){
		smax=smax>a[i]?smax:a[i];
	}
	return smax;
}
int sums(int x)
{
	cout<<"+++++++"<<x<<endl;
	int sum=0,sumci=0;
	for(int i=0;i<=n;i++){
		while(sum<x){
			sum+=a[i];
			i++;
			if(i>n) break;
		}
		//cout<<"00"<<sum<<endl;
		sumci++,sum=0;
	}
    cout<<sumci<<"?????"<<endl;
	return sumci;
}
int binarysearch()
{
	smax=999999;
	int sum=0,s=n+1-m,lucky=0,left,right,mid;
	left=0,right=l,funny;
	while(left<=right){
		mid=(left+right)/2;
		if(sums(mid)<s){
			right=mid-1;
		}
		else if(sums(mid)>s){
			left=mid+1;
		}
		else{
			int temp=sums(mid);
			if(smax>mid){
				smax=mid;
			}
			cout<<mid<<endl;
			right=mid-1;
		}
	}
	return smax;
}
int main()
{
	while(scanf("%d%d%d",&l,&n,&m)!=EOF){
		for(int i=0;i<n;i++){
			scanf("%d",&k[i]);
		}
		sort(k,k+n);
		a[0]=k[0],a[n]=l-k[n-1];
		for(int i=1;i<n;i++){
			a[i]=k[i]-k[i-1];
		}
		/*for(int i=0;i<=n;i++){
			cout<<" "<<a[i];
		}
		cout<<endl;*/
		if(n<m){
			smax=func();
		}
		else{
			smax=binarysearch();
		}
		printf("%d\n",smax);
	}
}

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=5e5+5;
int l,n,m;
int k[maxn];
bool judge(int x)
{
	int last=k[0],sum=0;
	for(int i=1;i<=n;i++){
		if(k[i]-k[i-1]>x) return false;
		if(k[i]-last>x){
			last=k[i-1];
			sum++;
			if(sum>=m) return false;
		}
	}
	return true;
}
int main()
{
	int left,right,mid,ans;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF){
		for(int i=1;i<=n;i++){
			scanf("%d",&k[i]); 
		}
		sort(k,k+n+1);
		k[++n]=l,k[0]=0;//这样处理比较好 
		left=0,right=l;
		while(left<=right){
			mid=(left+right)>>1;
			if(judge(mid)){
				ans=mid;
				right=mid-1;
			}
			else left=mid+1;
		}
		printf("%d\n",ans);
	}
}

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

猜你喜欢

转载自blog.csdn.net/DaDaguai001/article/details/84678642