Hdu 1669 Jamie's Contact Groups 二分图多重匹配+二分

题目:

Jamie is a very popular girl and has quite a lot of friends, so she always keeps a very long contact list in her cell phone. The contact list has become so long that it often takes a long time for her to browse through the whole list to find a friend's number. As Jamie's best friend and a programming genius, you suggest that she group the contact list and minimize the size of the largest group, so that it will be easier for her to search for a friend's number among the groups. Jamie takes your advice and gives you her entire contact list containing her friends' names, the number of groups she wishes to have and what groups every friend could belong to. Your task is to write a program that takes the list and organizes it into groups such that each friend appears in only one of those groups and the size of the largest group is minimized.

Input

There will be at most 20 test cases. Ease case starts with a line containing two integers N and M. where N is the length of the contact list and M is the number of groups. N lines then follow. Each line contains a friend's name and the groups the friend could belong to. You can assume N is no more than 1000 and M is no more than 500. The names will contain alphabet letters only and will be no longer than 15 characters. No two friends have the same name. The group label is an integer between 0 and M - 1. After the last test case, there is a single line `0 0' that terminates the input.

Output

For each test case, output a line containing a single integer, the size of the largest contact group.

Sample Input

3 2
John 0 1
Rose 1
Mary 1
5 4
ACM 1 2 3
ICPC 0 1
Asian 0 2 3
Regional 1 2
ShangHai 0 2
0 0

Sample Output

2
2

思路:

二分图多重匹配+二分。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1e3+5;
int n,m;
int head[maxn];
int match[maxn][maxn];
int vis[maxn];
int num[maxn];
struct edge
{
    int to;
    int next;
}edge[maxn*maxn*2];
void add (int id,int u,int v)
{
    edge[id].to=v;
    edge[id].next=head[u];
    head[u]=id;
}
bool Find(int x,int mid)
{
    for (int i=head[x];i!=-1;i=edge[i].next)
    {
        int u=edge[i].to;
        if(!vis[u])
        {
            vis[u]=1;
            if(num[u]<mid)
            {
                match[u][num[u]++]=x;
                return true;
            }
            for (int j=0;j<num[u];j++)
            {
                if(Find(match[u][j],mid))
                {
                    match[u][j]=x;
                    return true;
                }
            }
        }
    }
    return false;
}
bool algor (int mid)
{
    memset (num,0,sizeof(num));
    for (int i=0;i<n;i++)
    {
        memset (vis,0,sizeof(vis));
        if(!Find(i,mid)) return false;
    }
    return true;
}
int main()
{
    while(scanf("%d%d",&n,&m)&&(n||m))
    {
        memset (head,-1,sizeof(head));
        int cnt=0;
        for (int i=0;i<n;i++)
        {
            char s[200];
            scanf("%s",s);
            int x;
            char c;
            while(1)
            {
                scanf("%d%c",&x,&c);
                add(++cnt,i,x);
                if(c=='\n') break;
            }
        }
        int l=1,r=n;
        while(l<r)
        {
            int mid=(l+r)/2;
            if(algor(mid))
            {
                r=mid;
            }
            else
            {
                l=mid+1;
            }
        }
        printf("%d\n",r);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/88379351
今日推荐