HDU4430 Yukari's Birthday 二分

Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
 
  
18 111 1111
 

Sample Output
 
  
1 17 2 10 3 10

k>=2,所以r毛估估,应该是不会超过45的,枚举一下r,然后二分找k就可以了。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<queue>
#include<vector>
using namespace std;
long long n;
long long findk(long long x)
{//二分 
	long long l=2,r=n,mid,i,s,sum;
	while(l<=r)
	{
		mid=(l+r)/2;
		s=1;sum=0;
		for(i=1;i<=x;i++)
		{
			if(n/s<mid)
			{
				sum=n+1;
				break;
			}
			s*=mid;//k^i 
			sum+=s;//和 
			if(sum>n)break;//太大了 
		}
		if(sum==n||sum+1==n)//圆心可以放or不放 
		return mid;
		else if(sum<n-1)
		l=mid+1;
		else
		r=mid-1;
	}
	return -1; 
}
int main()
{
	long long i,j,r,k,s,o,p;
	while(scanf("%lld",&n)!=EOF)
	{
		r=1;k=n-1;
		s=n-1;
		for(i=2;i<=45;i++)//枚举r
		{
			o=findk(i);//new k
			p=o*i;//k*r
			if(o!=-1&&p<s)
			{
				s=p;
				r=i;k=o;//更新 
			}
		} 
		printf("%lld %lld\n",r,k);
	} 
}

猜你喜欢

转载自blog.csdn.net/thewise_lzy/article/details/79923000