POJ——3617题 Best Cow Line

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_40788630/article/details/87924882

Best Cow Line

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36747   Accepted: 9542

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

这个其实就是贪心,当前后两个字母不同时将比较小的输出,当两者相同时接着往里比较,直到不同为止

#include<iostream>
#include<queue>
using namespace std;
int n;
char s[2005];
int main()
{
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>s[i];
	}
	int a=0,b=n-1,t1=0;
	while(a<=b){
		t1++;
		bool left = false;//从左起和从右起的字母进行比较
		for(int i=0;a+i<b;i++){//这个循环是当左右两端相同时则分别移向下一个 
			if(s[a+i] < s[b-i]){
				left = true;//左边的首字母更小
				break; 
			}else if(s[a+i] > s[b-i]){
				left = false;//右边的首字母更小 
				break;
			}
		} 
		if(left)cout<<s[a++];
		else cout<<s[b--];
		if(t1%80==0)cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40788630/article/details/87924882
今日推荐