POJ 3617 Best Cow Line(字典序最小,贪心)

Best Cow Line

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32970   Accepted: 8716

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意:给定长度为 n 的字符串,要构造一个字符串 T,起初 T 是一个空串,随后可以有下列任意操作,1. 从 S 的头部删除一个字符,加到 T 的尾部。 2. 从S的尾部删除一个字符,加到T的尾部。 要求T 的字典序最小。

思路:很简单的贪心,每一次都比较字符串头和尾,小的那一个字符加入到T;如果相等 则往前比较。

注意:题目要求每 80 个字符就换行,不然PE;

AC代码:

#include<cstdio>
#include<algorithm>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define INT(t) int t; scanf("%d",&t)
#define LLI(t) LL t; scanf("%I64d",&t)

using namespace std;

char a[3000];

int main() {
    int n;
    while(~scanf("%d", &n)) {
        rep(i, 0, n) scanf(" %c", &a[i]);
        char ans[3000] = {0};
        int pa = 0;
        int l = 0, r = n - 1;
        rep(i, 0, n) {
            if(r < l) break;
            if(a[l] < a[r]) {
                ans[pa ++] = a[l];
                l ++;
            } else if(a[l] > a[r]) {
                ans[pa ++] = a[r];
                r --;
            } else {
                int cnt = 0;
                while(a[l + cnt] == a[r - cnt])
                    cnt ++;
                if(a[l + cnt] < a[r - cnt]) {
                    ans[pa ++] = a[l];
                    l ++;
                } else if(a[l + cnt] > a[r - cnt]) {
                    ans[pa ++] = a[r];
                    r --;
                }
            }
        }
        int coun = 0;
        rep(i,0,n){
            printf("%c",ans[i]);
            coun ++;
            if(coun == 80){
                printf("\n");
                coun = 0;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_O_ac/article/details/82463269
今日推荐