Best Cow Line - poj3617 - 贪心

Best Cow Line

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32165   Accepted: 8530

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

USACO 2007 November Silver

思路:

wa了好几遍才意识到,当我们选首or尾的时候,我们优先选最小的,当首尾相等时,比较下一个字符的大小,选小的,若还相同,则比较下下一个,选小的,以此类推。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
 
using namespace std;
char s[2005],c[2005];
int main(){
	int N;
	scanf("%d",&N);
	getchar();
	for(int i=0;i<N;i++){
		scanf("%c",&s[i]);
		getchar();
	}
	int m=0,b=0,e=N-1;
	
	while(b<=e){
		bool flag=false;
		for(int i=0;b+i<=e;i++){
			if(s[b+i]<s[e-i]){
				flag=true;
				break;
			}
			else if(s[b+i]>s[e-i]){
				flag=false;
				break;
			}
			else continue;
		}
		if(flag)c[m++]=s[b++];
		else c[m++]=s[e--];
	}
	for(int i=0;i<m;i++){
		printf("%c",c[i]);
		if((i+1)%80==0)printf("\n");
	}
	if(m%80)printf("\n");
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81271357