POJ 3617 Best Cow Line 贪心

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意:

 给定一个字符串S, 要构造一个长为N的字符串T, 起初T是一个空串, 随后反复进行下列任意操作。

  1. 从S的头部删除一个字符, 加到T的尾部
  2. 从S的尾部删除一个字符, 加到T的尾部

要求构成一个字典序尽量小的字符串。

显然, 这题需要用贪心, 很容易想到的是比较头部和尾部, 看看那个小就删除哪个, 但是遇到字符相等的时候就无从下手。

正确的做法是, 比较正序和倒序的字符串大小, 那个小就删除哪个字符。

注意,此题需要80个字符一行,到了80个自动换行。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=2005;
int n;
int len;
char s[maxn];
char s1[maxn];
int main()
{
    scanf("%d",&n);
    getchar();
    for (int i=0;i<n;i++)
        {
            scanf("%c",&s[i]);
            getchar();
            s1[n-i-1]=s[i];
        }
    int numa=0,numb=0;
    int num=0;
    while (num<n)
    {
        int loca=numa,locb=numb;
        while (s[loca]==s1[locb]&&loca<n&&locb<n)
        {
             loca++;
             locb++;
        }
        if(loca<n&&locb<n&&s[loca]>s1[locb])
        {
            printf("%c",s1[numb++]);
        }
        else
            printf("%c",s[numa++]);
        num++;
        if(num%80==0)
            printf("\n");
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81562417
今日推荐