poj3617 best cow line(贪心题)

Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32687   Accepted: 8660

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意:字符串头和尾取出来,组成字典序最小的字符串
题解:贪心处理,倒序比较
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=304;

int N;
char a[2005];

int ans=1;

void solve(int k)
{
    ans=0;
    int p=0,q=k-1;
    while(q>=p)
    {
        int left=0;
        for(int i=0;i+p<=q;i++)
        {
            if(a[p+i]<a[q-i])
            {
                left=1;
                break;
            }
            else if(a[p+i]>a[q-i])
            {
                left=0;
                break;
            }
        }
        if(left)
        {
            printf("%c",a[p++]);
            ans++;
        }
        else
        {
            printf("%c",a[q--]);
            ans++;
        }
        
        if(ans%80==0)
            cout<<endl;
    }
    printf("\n");
}
int main()
{
    
    cin>>N;
    getchar();
    for(int i=0;i<N;i++)
    {
        cin>>a[i];
    }
    
    solve(N);
}

猜你喜欢

转载自www.cnblogs.com/smallhester/p/9499837.html