ACM1013:Digital Roots

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those
digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12.
Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit
and also the digital root of 39.
 
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 
Output
For each integer in the input, output its digital root on a separate line of the output.
 
Sample Input
24
39
0
 
Sample Output
6
3
--------------------------------------------------------------------------------------------------------
一个数和它各位数的和同模。
证明:

首先n=d1+10d2+…+10m-1dm。则n= 9d2+…+(10m-1-1)dm+ d1+d2+…+dm,把所有的位数相加结果就是9的倍数取余,余数为n=d1+d2+…+dm,所以n与n’同模。最终,经过不断取余,n会化为个位数。

10i=1i=1

 

f(x)=x(mod 9)

f(f(x)) = f(x) = x(mod 9)

完整的公式为

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#define SIZE 100000
char n[SIZE];
int main()
{
	int ans, length;
	while (scanf("%s", n)== 1 && n[0] != '0')
	{
		ans = 0;
		length = strlen(n);
		for (int i = 0; i < length; i++)
		{
			ans += n[i] - '0';
		}

		printf("%d\n", ans%9==0?9:ans%9);
	}
	return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/mycodinglife/p/10539451.html