HDU-1085 Holding Bin-Laden Captive! (母函数)

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3
0 0 0

Sample Output

4

题意:给出x,y,z,三个数,代表x个1元硬币,y个2元硬币,个三元硬币,问最小的无法支付数目是多少。

思路:母函数

#include<algorithm>
#include<string.h>
using namespace std;
int a,b,c,maxx;
int A[10000],B[10000];
void see()
{
    for(int i=1;i<=maxx;i++)
    {
        printf("%d ",B[i]);
    }printf("\n");
}
int main()
{
    while(~scanf("%d%d%d",&a,&b,&c),a||b||c)
    {
        maxx=a+2*b+5*c;
        memset(A,0,sizeof(A));
        memset(B,0,sizeof(B));
        for(int i=0;i<=a;i++)
            A[i]=1;
        for(int j=0;j<=maxx;j++)
        {
            for(int i=0;i<=b;i++)
            {
                B[2*i+j]+=A[j];
            }
        }
        memset(A,0,sizeof(A));
        for(int i=0;i<=c;i++)
        {
            for(int j=0;j<=maxx;j++)
            {
                A[5*i+j]+=B[j];
            }
        }
        for(int i=1;i<=maxx+1;i++)
        {
            if(A[i]==0)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/84860699