hdu1085(普通母函数)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yu121380/article/details/84329383

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26528    Accepted Submission(s): 11681

Problem Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3

0 0 0

Sample Output

4

解析:母函数模板

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

const int maxn=8e3+5;
struct node{
	int val,cnt;
}num[3];
int c1[maxn],c2[maxn];

int main()
{
	num[0].val=1,num[1].val=2,num[2].val=5;
	while(~scanf("%d%d%d",&num[0].cnt,&num[1].cnt,&num[2].cnt))
	{
		if(num[0].cnt==0 && num[1].cnt==0 && num[2].cnt==0)break;
		
		int mav=num[0].cnt*num[0].val+num[1].cnt*num[1].val+num[2].cnt*num[2].val;
		mem(c1,0);
		mem(c2,0);
		for(int i=0; i<=num[0].cnt; i++)
		{
			c1[i]=1;
		}
		for(int i=1; i<3; i++)
		{
			for(int j=0; j<=mav; j++)
			{
				for(int k=0; k+j<=mav && k<=num[i].cnt*num[i].val; k+=num[i].val)
				{
					c2[j+k]+=c1[j];
				}
			}
			for(int j=0; j<=mav; j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		int i;
		for(i=1; i<=mav; i++)
		{
			if(!c1[i])break;
		}
		
		printf("%d\n",i);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/84329383
今日推荐