hdu3294 Girl'sResearch manacher算法求最长回文串长度,起点,终点

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps: 
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input

Input contains multiple cases. 
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase. 
If the length of string is len, it is marked from 0 to len-1.

Output

Please execute the operation following the two steps. 
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!". 
If there are several answers available, please choose the string which first appears.

Sample Input

b babd
a abcd

Sample Output

0 2
aza
No solution!
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1000005
using namespace std;
int sum[maxn];
char s[maxn*2];
char ss[maxn*2];
int p[maxn*2];
char op[maxn];
int len;
int id;
int maxlen;
int l,r;
void init()
{

    for(int i=len;i>=0;i--)
    {
        ss[i+i+2]=s[i];
        ss[i+i+1]='#';
    }
    ss[0]='*';
    ss[2*len+2]=0;
}
int manacher()
{id=0;
maxlen=0;
    for(int i=2;i<2*len+1;i++)
    {
        if(p[id]+id>i)
            p[i]=min(p[2*id-i],p[id]+id-i);
        else
            p[i]=1;
        while(ss[i-p[i]]==ss[i+p[i]])
            ++p[i];
        if(id+p[id]<i+p[i])
            id=i;
        if(maxlen<p[i])
            {maxlen=p[i];
            l=(i-p[i])/2;
            r=(i+p[i])/2-2;
    }
    }
    return maxlen-1;
}
int main()
{l=0,r=0;

    while(~scanf("%s%s",op,s))
    {int a=op[0];
    len=strlen(s);
init();
int w=manacher();

if(w<2)
    printf("No solution!\n");


    else
    {
       printf("%d %d\n",l,r);
       int x=a-'a';
       for(int i=l;i<=r;i++)
       {
           if(s[i]-'a'>=x)
            printf("%c",s[i]-x);
           else
            printf("%c",s[i]+26-x);

       }
       printf("\n");
    }
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/87990106