HDU - 3294——Girls' research (最长回文位置+字符转换)

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
Input Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1. Output Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears. Sample Input
b babd
a abcd
Sample Output
 
 

0 2azaNo solution!

题意:求最长回文的位置(最长回文小于2输出 No solution!),转换字符,给定一个字符,这个字符代表a。这个字符后一位的代表b,再后一位代表c。如样例1:b代表a,则c代表b........z代表y,a代表z.
思路:manacher加字符转换
#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 200010
using namespace std;
char a[M],b[2*M],c[5];
int p[2*M],len,l;
int init()
{
    l=0;
    b[l++]='!';
    len=strlen(a);
    for(int i=0; i<len; i++)
    {
        b[l++]='#';
        b[l++]=a[i];
    }
    b[l++]='#';
    b[l]='&';
}
int manacher()
{
    init();
    int id,ma=0;
    for(int i=1; i<l; i++)
    {
        if(ma>i)
            p[i]=min(p[2*id-i],ma-i);
        else
            p[i]=1;
        while(b[i+p[i]]==b[i-p[i]])p[i]++;
        if(i+p[i]>ma)
        {
            ma=i+p[i];
            id=i;
        }
    }
}
int main()
{
    int ans,ri,li,pan;
    while(~scanf("%s%s",c,a))
    {
        pan=c[0]-'a';
        ans=0;
        manacher();
        for(int i=1; i<l; i++)
        {
            if(p[i]>ans)
            {
                ans=p[i];
                ri=(i-p[i])/2;
                li=(i+p[i]-3)/2;
            }
        }
        if(ans>=3)
        {
            printf("%d %d\n",ri,li);
            for(int i=ri;i<=li;i++)
            {
                printf("%c",(a[i]-'a'-pan+26)%26+'a');
            }
            printf("\n");
        }
        else
            printf("No solution!\n");
    }
}

。加上字符转换。

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80289598
今日推荐