HDU3294 Girls' research

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 5730    Accepted Submission(s): 2126

Problem Description

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input

Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.

Output

Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.

Sample Input

b babd a abcd

Sample Output

0 2 aza No solution!

这题算是一道马拉车算法的模板题,除了套用模板,我觉得有几点得注意:

①存放以第i个字符为中心轴,两边字符轴对称的最大半径的p[i]最好要开两倍的原字符串长度的大小,同理str数组也要;

②字母转换;

③要对选定的id做个标记index,因为要输出原字符串中最长回文子序列,同时也要计算出最长回文子序列长度;

马拉车算法模板:

/*马拉车算法需要对字符串进行预处理*/
    int len=strlen(str);
    for(int i=2*len+1; i>0; i-=2)
    {
        str[i]='#';
        str[i-1]=str[i/2-1];
    }
    str[0]='@';
    str[2*len+2]='\0';
/*全代码*/
void Manacher()
{
    int len=strlen(str);
    int maxs=0;
    for(int i=2*len+1; i>0; i-=2)
    {
        str[i]='#';
        str[i-1]=str[i/2-1];
    }
    str[0]='@';
    str[2*len+2]='\0';
    int p[100000];
    //cout<<str<<endl;
    memset(p,0,sizeof(p));
    int mx=0,id=0;
    for(int i=1; i<2*len+1; i++)
    {
        p[i]=mx>i?mins(p[2*id-i],mx-i):1;
       // cout<<str[i+p[i]]<<" "<<i<<" "<<str[i-p[i]]<<endl;
        while(str[i+p[i]]==str[i-p[i]])p[i]++;
        if(mx<i+p[i])
        {
            mx=i+p[i];
            id=i;
        }
        //if(maxs<p[i])maxs=p[i]-1;
    }
  //  cout<<maxs<<endl;
}

本题代码如下(AC):

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#define maxn 200010
using namespace std;
int n,id,maxlen,maxs,index,len,p[maxn*2];    
char chr[5],str[maxn*2];
void manacher(char str[],int n){
    id=0;
    maxlen=0;
    maxs=0;
      for(int i=2;i<n;i++){
          p[i]=maxlen>i?min(p[2*id-i],maxlen-i):1;
          while(str[i-p[i]]==str[i+p[i]]) p[i]++;
          if(maxlen<p[i]+i) {
              maxlen=p[i]+i;
              id=i;
          }
          if(maxs<p[i]){
              maxs=p[i];
              index=i;
          }
      }
}
int main(){
  while(scanf("%s%s",chr,str)!=EOF){
      len=strlen(str);
      int s=chr[0]-'a';
      for(int i=0;i<len;i++){
          if(str[i]-'a'>=s) str[i]=str[i]-s;
          else str[i]=str[i]-s+26;
      }
    for(int i=2*len+1;i>0;i-=2){
        str[i]='#';
        str[i-1]=str[i/2-1];
    }
        str[0]='@';
        str[2*len+2]='\0';
        manacher(str,2*len+1);
        maxs=maxs-1;
        int k=maxs/2;
        if(k==0) {
        printf("No solution!\n");
        continue;
    }
        else{
            int L=index-maxs+1;
            int R=index+maxs-1;
            printf("%d %d\n",(L-2)/2,(R-2)/2);
            for(int i=L;i<=R;i++)
                if(str[i]!='#') printf("%c",str[i]);
                printf("\n");
        }
  }
  return 0;    
}

猜你喜欢

转载自www.cnblogs.com/jianqiao123/p/11297958.html
今日推荐