PAT 甲级 1124 Raffle for Weibo Followers

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87904888

1124 Raffle for Weibo Followers (20 point(s))

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

经验总结:

题目很简单,转发抽奖,每隔一个固定值抽一个,如果这个人中过奖了,顺次到下一个人,如果下一个还中过了,继续顺次,就不多说啦~

AC代码

#include <cstdio>
#include <map>
#include <string>
using namespace std;
const int maxn=30;
int n,m,s;

int main()
{
	scanf("%d%d%d",&m,&n,&s);
	char str[25];
	map<string,bool> mp;
	int x=s;
	for(int i=1;i<=m;++i)
	{
		scanf("%s",str);
		if(i==x&&mp.count(str)==0)
		{
			mp[str]=true;
			printf("%s\n",str);
			x+=n;
		}
		else if(i==x&&mp.count(str)!=0)
		{
			++x;
		}
	}
	if(x==s)
		printf("Keep going...\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87904888
今日推荐