1124 Raffle for Weibo Followers(20 分)(cj)

1124 Raffle for Weibo Followers(20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

code

#pragma warning(disable:4996)
#include <iostream>
#include <algorithm>
#include <set>
#include <string>
#include <vector>
using namespace std;
int main() {
	int m, n, s;
	string str;
	set<string> ss;
	vector<string> vstr;
	cin >> m >> n >> s;
	for (int i = 0; i < m; ++i) {
		cin >> str;
		vstr.push_back(str);
	}
	int i = s-1;
	bool f = 1;
	while (i<m) {
		if (ss.find(vstr[i]) != ss.end()) {
			i++;
			continue;
		}
		cout << vstr[i] << endl;
		f = 0;
		ss.insert(vstr[i]);
		i += n;
	}
	if (f) cout << "Keep going..." << endl;
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82656575
今日推荐