【PAT】A1124 Raffle for Weibo Followers (20point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1124 Raffle for Weibo Followers (20point(s))

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going…

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <map>
using namespace std;
vector<string> winner,nicknames;
map<string,bool> appr;
int main(){
    int m,n,s;
    cin>>m>>n>>s;
    nicknames.resize(m+1);
    for(int i=1;i<=m;i++){
        cin>>nicknames[i];
        appr[nicknames[i]]=false;
    }
    for(int i=s;i<=m;i+=n){
        while(appr[nicknames[i]]==true) i++;    
        winner.push_back(nicknames[i]);
        appr[nicknames[i]]=true; 
    }
    for(int i=0;i<winner.size();i++)    cout<<winner[i]<<endl;
    if(winner.size()==0)    cout<<"Keep going...\n";
    return 0;
}

Analysis

-注意看懂题,去除重复的人排序,无视刷屏者

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103967065