1124 Raffle for Weibo Followers (20 分)

版权声明:SupremeBeast3_ https://blog.csdn.net/weixin_43359312/article/details/89149611

1124 Raffle for Weibo Followers (20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going…

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main() {
	char Person[1001][21];
	int cnt = 0, k = 0;
	int M, N, S;	//转发的总量 中奖间隔 第一位中奖者的序号
	cin >> M >> N >> S;
	for (int i = 1; i <= M; i++) scanf("%s", Person[i]);	//得到转发人的昵称
	int Lucky[1001] = { 0 };
	if (S > M) { printf("Keep going...\n"); return 0; }	//第一位中奖者超出总人数
	printf("%s\n", Person[S]);
	Lucky[k++] = S;		//得到第一位中奖者 标记其已中过奖
	if (N + S > M) return 0;	//如果下位中奖者超出总人数
	for (int i = S+1; i <= M; i++) {
		cnt++;
		if (cnt == N) {
			int flag = 1;
			for (int j = 0; j < k; j++)		//如果此人已领过奖
				if (strcmp(Person[i], Person[Lucky[j]]) == 0) { flag = 0; break; }
			if (flag) {
				Lucky[k++] = i;		//标记其已中过奖
				printf("%s\n", Person[i]);
				cnt = 0;	//重新计数
			}
			else cnt--;		//已领过奖的人作废 不做计数
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43359312/article/details/89149611