PAT(A) 1124. Raffle for Weibo Followers (20)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79527954

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1124

1124. Raffle for Weibo Followers (20)


John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print “Keep going…” instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going…

题目大意

输入M(粉丝数)、N(每N个人一个),S(开始位置,起始点为1)。找出获得奖的人,对于已获得的人,跳过处理。

代码

/*
* Problem: 1124. Raffle for Weibo Followers (20)
* Author: HQ
* Time: 2018-03-12
* State: Done
* Memo: 
*/
#include "iostream"
#include "vector"
#include "map"
#include "string"
using namespace std;

vector<string> followers;
vector<string> win;
map<string,bool> winner;
int M,N,S;

int main() {
    cin >> M >> N >> S;
    followers.resize(M);
    for (int i = 0; i < M; i++) {
        cin >> followers[i];
    }
    for (int j = 0, i = S - 1; i < M; i++) {
        if (j % N == 0) {
            if (winner[followers[i]])
                continue;
            else {
                winner[followers[i]] = true;
                win.push_back(followers[i]);
            }
        }
        j++;
    }
    if (!win.size())
        cout << "Keep going..." << endl;
    for (int i = 0; i < win.size(); i++) {
        cout << win[i] << endl;
    }
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79527954