pat Counting Leaves

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wulianwangxuchenqi/article/details/79773009

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1
就是求每一层不是叶子节点的个数
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
vector <int>G[105];
int flag[105];
int height;
void dfs(int u, int num){
	if(G[u].empty()){
		flag[num]++;
		return;
	}
	int cur;
	for(int i =0;i<G[u].size();i++){
		cur = G[u][i];
		height=max(height,num+1);
		dfs(cur,num+1);
	}
}
int main(){
	int N,M, n,k,a;
	scanf("%d%d", &N, &M);
	memset(flag,0,sizeof(flag));
	for(int i = 0; i < M; i++){
		scanf("%d%d", &n, &k);
		for(int j = 0; j < k;j++){
			scanf("%d", &a);
			G[n].push_back(a);
		}
	}
	height=1;  //考虑节点数只有一个,不能赋值为-1 
	dfs(1,1);
	for(int i =1;i<height;i++){
		printf("%d ", flag[i]);
	}
	printf("%d",flag[height]);
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/wulianwangxuchenqi/article/details/79773009
今日推荐