PAT:1004. Counting Leaves (30)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34621169/article/details/51475329

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

提交代码



n个结点,接下来m行,每行第一个表示父节点,后面跟着一个k表示有k个子节点,后面k个都是子节点

#include <iostream>
#include <cstring>
using namespace std;
struct node {
    int nochild;
    node* first_child;
    node* next_sibling;
};
int count[100];
int MAX;
void find(node *current,int level)
{
    if(level > MAX)
        MAX = level;
    if(current->nochild == 1)
        count[level]++;
    else
        find(current->first_child,level+1);
    if(current->next_sibling!=NULL)
        find(current->next_sibling,level);
    return;
}
int main(){
    int n,m;
    cin>>n>>m;
    node *array[300];
    node *temp;
    memset(count,0,sizeof(count));
    for(int i=1;i<=n;i++){
        array[i]=new node;
        array[i]->nochild = 1;
    }
    for(int i=0;i<m;i++){
        int root,k,in;
        cin>>root>>k>>in;
        array[root]->nochild=0;
        array[root]->first_child=array[in];
        temp=array[in];
        for(int j=1;j<k;j++){
            cin>>in;
            temp->next_sibling=array[in];
            temp=array[in];
        }
    }
    MAX=1;
    find(array[1],MAX);
    for(int i=1;i<MAX;i++)
        cout<<count[i]<<" ";
    cout<<count[MAX];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34621169/article/details/51475329