【PAT】PAT Advanced 1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意

在一个家族中假设有n名成员(编号1-n),求有几个成员是没有儿子的。

思路

乍一看这是一道建树的问题,实际可不用建树,使用一个parent数字来存储每个成员的父辈,遍历一遍生成children向量数组记录每一个成员的儿子辈分。最后dfs遍历。

代码

//
//  main.cpp
//  PAT1004
//
//  Created by 许少钧 on 2019/4/8.
//  Copyright © 2019年 许少钧. All rights reserved.
//

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
using namespace std;
const int MAX_N = 101;
vector<int> children[MAX_N];
int maxFloor = 0;
int leafEveryFloor[MAX_N];
void dfs(int p, int floor){
    maxFloor = max(floor, maxFloor);
    const long l = children[p].size();
    if(l == 0){
        leafEveryFloor[floor]++;
        return;
    }
    floor++;
    for(int i = 0; i < l; i++){
        dfs(children[p][i], floor);
    }
}
int main() {
    int n, m, id, k, child;
    scanf("%d %d", &n, &m);
    while (m-- > 0) {
        scanf("%d %d", &id, &k);
        while (k-- > 0) {
            scanf("%d", &child);
            children[id].push_back(child);
        }
    }
    dfs(1, 0);
    printf("%d", leafEveryFloor[0]);
    for(int i = 1; i <= maxFloor; i++){
        printf(" %d", leafEveryFloor[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a617976080/article/details/89088553