求树每一层叶子结点个数

传送门

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <vector>
#include <string.h>
using namespace std;

vector<int> a[100];//树
int f[100];//某一层叶子结点个数
int m,n;
int d;//深度

int dfs(int i,int deep)//当前节点,当前深度
{
	int l=a[i].size();
	if(l==0) f[deep]++;
	for(int j=0;j<l;j++)
	{
		int to=a[i][j];
		dfs(to,deep+1);
	}
	d=max(d,deep+1);
}

int main()
{
	scanf("%d%d",&n,&m);
	d=0;
	memset(f,0,sizeof(f));
	for(int i=0;i<100;i++) a[i].clear();
	while(m--)
	{
		int id,k;
		scanf("%d%d",&id,&k);
		for(int i=0;i<k;i++)
		{
			int b;
			scanf("%d",&b);
			a[id].push_back(b);
		}
	}
	dfs(1,1);
	for(int i=1;i<d-1;i++)
	    printf("%d ",f[i]);
	printf("%d\n",f[d-1]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41383801/article/details/87897703