白银组第五题

汉字统计
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62489 Accepted Submission(s): 33636

Problem Description
统计给定文本文件中汉字的个数。

Input
输入文件首先包含一个整数n,表示测试实例的个数,然后是n段文本。

Output
对于每一段文本,输出其中的汉字的个数,每个测试实例的输出占一行。

[Hint:]从汉字机内码的特点考虑~

Sample Input
2
WaHaHa! WaHaHa! 今年过节不说话要说只说普通话WaHaHa! WaHaHa!
马上就要期末考试了Are you ready?

Sample Output
14
9

#include <iostream>
#include<string>
using namespace std;

int main()
{
	int n;
	int count = 0;
	cin >> n;
	getchar();
	string *s=new string[n];
	for (int i = 0; i < n; i++)
	{
		getline(cin,s[i]);
		
	}
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; s[i][j] != '\0'; j++)
		{
			if (s[i][j] <= 0 || s[i][j] >= 126)
				count++;
		}
		cout << count / 2;
		count = 0;
		if(i!=n-1)
		cout <<'\n';
	}
	
}

猜你喜欢

转载自blog.csdn.net/weixin_43981207/article/details/85011105