HDU - 1159(动态规划、最大上升子数列)

Time limit 1000 ms
Memory limit 32768 kB
OS WindowsSource
Southeastern Europe 2003

题目:
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Input
abcfbc abfcab
programming contest
abcd mnp
Output
4
2
0
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;


int main()
{
	char a[500], b[500];
	int dp[500][500];
	int x, y;
	while (cin >> a >> b)
	{
		memset(dp, 0, sizeof(dp));
		x = strlen(a);
		y = strlen(b);
		for (int i = 1; i <= x; i++)
			for (int t = 1; t <= y; t++)
			{
				if (a[i - 1] == b[t - 1])dp[i][t] = dp[i - 1][t - 1] + 1;
				else dp[i][t] = max(dp[i - 1][t], dp[i][t - 1]);
			}
		cout << dp[x][y] << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43967023/article/details/86615266