POJ 2631

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=1e6+7;
struct EDGE
{
	int u,v,w,next;
}eg[maxn];

int head[maxn],num;
//存图,用静态链表,什么是静态链表? 有一个头节点,然后用头插法
//每一个节点有一个指针,只想下一个元素,使用数组实现的。 
void add(int u, int v,int w)
{
	eg[num].u = u;
	eg[num].v = v;
	eg[num].w = w;
	eg[num].next = head[u];
	head[u] = num++;
}

queue<int> q;
int ans,dis[maxn],vis[maxn],node;

void BFS( int s)
{
	 
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
	//入队 
    q.push(s);
    vis[s] = 1;
    dis[s] = 0;
    ans =0;
    
	while(!q.empty())//深搜结束条件 
	{
		int u = q.front();
		q.pop();
		for( int i=head[u];i!=-1;i = eg[i].next) //图的遍历 
		{
			int v =eg[i].v;
			if(vis[v]==0 &&  dis[v] < dis[u] + eg[i].w ) 
		      	{
		      		// 对距离进行维护 
		      		dis[v] = dis[u] + eg[i].w;
		      		if( ans <dis[v] )
		      		{
		      			//找出最大距离 
		      			ans = dis[v];
		      			node = v;
					  }
				  vis[v] = 1;//用完以后就没用了 
				  q.push(v);//所以就出队 
				  }
		 	  
		}
		
	 } 
	 
	
 } 
int main(void)
{
	int u,v,w;
	memset(head,-1,sizeof(head));
	while(scanf("%d%d%d",&u,&v,&w)!=EOF){
		
		add(u,v,w);
		add(v,u,w);
	}
	
	BFS(1);
	BFS(node);
	printf("%d\n",ans);
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/81394309
今日推荐