HDU6322Euler Function(打表找规律)

HDU6322Euler Function

Problem Description

In number theory, Euler’s totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1 itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2
1
2

Sample Output

5
7

题意

假的数论题呐呐
φ(n)是所有比n小的正整数里跟n的最大公因数是1的数的个数
给一个k
问第k个φ(n)不是1或质数的n

思路

这个题写一下看起来n == 7之后都是偶数了
然后打表看一下的确是这样
就酱,啾咪

AC代码

#include<cstdio>
#include<iostream>

using namespace std;
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int k;
        scanf("%d", &k);
        if(k == 1)
            printf("5\n");
        else
            printf("%d\n", 5 + k);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wuswi0412/article/details/81431648
今日推荐