HDU - 5573 Binary Tree (构造进阶)

版权声明:本文为博主原创文章,转载请附上注明就行_(:з」∠)_。 https://blog.csdn.net/vocaloid01/article/details/82389992

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.
Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.
And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.
Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.
Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.
He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.
Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.
Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤10^9.

⋅ N≤2^K≤2^60

Output

For every test case, you should output " Case #x:" first, where x indicates the case number and counts from 1.
Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input

2
5 3
10 4

Sample Output

Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 + 

题解:

根据题中“ N≤2^K≤2^60”的提示我们容易想到做法肯定跟2^K有关,然后我们可以发现由树最左侧的点就可以组成1~2^K的值。所以本题只需考虑最左侧的点就行了(最后一个点为2^(K-1)或2^(K-1)+1可以根据N奇偶特判)。

首先我们先求得1~2^(K-1)的和(可以通过2^K-1得到),然后我们目标得到结果为N。

那么我们的目标就是减去sum = (2^K-1)-N,但是直接减的话相当于从N+sum变成N-sum,是减了两倍的sum,那么我们可以让

sum = (sum+1) / 2。剩下的看代码就可以理解了。

代码:

#include <cstdio>

using namespace std;

typedef long long LL;

int main()
{
    int T;
    scanf("%d",&T);
    int N,K;
    for(int _=1 ; _<=T ; ++_)
    {
       printf("Case #%d:\n",_);
       scanf("%d %d",&N,&K);
       LL n = 1<<K;
       LL sum = (n-1-N+1)/2;
       LL tmp = 1;
       for(int i=1 ; i<K ; ++i)
       {
           printf("%lld ",tmp);
           if(sum&tmp) puts("-");
           else puts("+");
           tmp <<= 1;
       }
       if(N&1) printf("%lld +\n",tmp);
       else printf("%lld +\n",tmp+1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/vocaloid01/article/details/82389992
今日推荐