PAT甲级 1076 Forwards on Weibo (30 分)BFS 图的遍历

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意:微博用户每个人都有粉丝,如果一个人发了新消息,那么关注他的用户都户转发,依次递推下去。转发的层数最多为L层,问转发的人数最多是多少。

解析思路: 先将用户关系图用二维vector存储好,然后用BFS遍历图,图中的queue除了记录结点外还要记录对应层数即可。Count记录用户数量。

注意:因为计算的是图(图、图、图,重要的事提醒三遍)的层数,所以只能使用BFS,用DFS是错误的!

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;

int N,L,m;
vector<vector<int>> e(1001);
bool vst[1001];

int bfs(int node){
	int count = 0;
	queue<pair<int,int>> que;
	que.push(pair<int,int>(node,0));
	vst[node] = true;
	while(!que.empty()){
		int v = que.front().first;
		int l = que.front().second;
		que.pop();
		if(l >= L)
			break;
		for(int i=0;i<e[v].size();i++){
			if(vst[e[v][i]] == false){
				vst[e[v][i]] = true;
				que.push(pair<int,int>(e[v][i],l+1));
				count++;
			}
		}
	}
	return count;
}

int main(){
	fill(vst,vst+1001,false);
	cin>>N>>L;
	for(int i=1;i<=N;i++){
		int num,b;
		cin>>num;
		for(int j=0;j<num;j++){
			cin>>b;
			e[b].push_back(i);
		}
	}
	cin>>m;
	while(m--){
		fill(vst,vst+1001,false);
		int node;
		cin>>node;
		cout<<bfs(node)<<endl;
	}
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82974530