HDU5835 Danganronpa【水题】

Danganronpa

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1613 Accepted Submission(s): 1010

Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

  1. Each table will be prepared for a mysterious gift and an ordinary gift.

  2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

  3. There are no limits for the mysterious gift.

  4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?

Input
The first line of input contains an integer T(T≤10) indicating the number of test cases.

Each case contains one integer n. The next line contains n (1≤n≤10) numbers: a1,a2,...,an, (1≤ai≤100000).

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.

Sample Input
1
2
3 2

Sample Output
Case #1: 2

Author
UESTC

Source
2016中国大学生程序设计竞赛 - 网络选拔赛

问题链接HDU5835 Danganronpa
问题简述
    n种礼物,已知每种礼物的数量,相邻同学的礼物不能相同,问有多少个同学能拿到符合要求的礼物。
问题分析
    水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU5835 Danganronpa */

#include <stdio.h>

int main(void)
{
    int t, caseno = 0, n, sum, a, i;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        sum = 0;
        for(i = 1; i <= n; i++) {
            scanf("%d", &a);
            sum += a;
        }

        printf("Case #%d: %d\n", ++caseno, sum / 2);
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10206134.html