hdu1020Encoding 水题

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52289    Accepted Submission(s): 23245


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
 
  
2 ABC ABBCCC
 

Sample Output
 
  
ABC A2B3C
 

Author
#include<stdio.h>
#include<string.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{	
	    char a[10050];
		scanf("%s",a);
		for(int i=0;a[i]!='\0';)
		{   
			int sum=1;
			while(a[i]==a[i+1])
			{
				sum++;
				i++;
		    }
			if(sum==1)
			printf("%c",a[i]);
			else 
			printf("%d%c",sum,a[i]);
			i++;
		}
		printf("\n");
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/cao2219600/article/details/80084643