HDU - 1800 Flying to the Mars(水题)

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
Output
For each case, output the minimum number of broomsticks on a single line.
Sample Input
4
10
20
30
04
5
2
3
4
3
4
Sample Output
1
2

题意:给出n个数值,数值大的可以教数值小的,一连串下来,将形成几串序列,表示序列中大的教小的,如2 3 4 3 4 ,排序后变为2 3 3 4 4,可以分为两个序列,4教3 ,和 4教3教2,现在问如何分可以分出最少的序列个数。输出最小序列个数。

可以这样想,我们排序之后取出从小到大取出每个数,然后检查每个分好的序列的最大元素是否小于取出的数,若小于,可以将取出的数接到那个序列上,这样取出的数就成了那个序列里最大的数,若小于等于所有序列的最大值,那么我们只能开出一个新的序列来存放,最后直接输出有多少个这样 序列即可。

#include<bits/stdc++.h>
using namespace std;
const int maxn=3e3+9;
int ans[maxn];
int main()
{
    int n,a[maxn],cnt;
    while(scanf("%d",&n)!=EOF)
    {
        cnt=0;
        for(int i=1; i<=n; i++)scanf("%d",&a[i]);
        sort(a+1,a+1+n);
        for(int i=1; i<=n; i++)
        {
            int tmp=-1;
            for(int j=0; j<cnt; j++)
            {
                if(a[i]>ans[j])
                {
                    tmp=j;
                    break;
                }
            }
            if(tmp==-1)ans[cnt++]=a[i];
            else ans[tmp]=a[i];
        }
        printf("%d\n",cnt);
    }
}

猜你喜欢

转载自blog.csdn.net/kuronekonano/article/details/80220124