PAT A1011

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

 题意:

给出三场比赛的赔率,正确率为 65 %, 每次投注 2元,问最大期望投入,并输出最大收入时的比赛结果

思路:

令 ans 记录最大收益,初值为 1.0 

每读入一行,就找到该行最大的数字,并输出其下标所对应的输赢情况,同时令 ans 累乘该最大值。

#include <cstdio>
char S[3] = {'W', 'T', 'L'};
int main(){
	double ans = 1.0, temp, a;
	int idx;
	for(int i = 0; i < 3; i++){
		temp = 0.0;
		for(int j = 0; j < 3; j++){
			scanf("%lf", &a);
			if(a > temp){
				temp = a;
				idx = j;
			}
		}
		ans *= temp;
		printf("%c ", S[idx]);
	}
	printf("%.2f", (ans * 0.65 - 1 ) * 2);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gsj9086/article/details/85383675
今日推荐