【PAT】A1011 World Cup Betting (20point(s))

A1011 World Cup Betting (20point(s))

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

Code

#include <stdio.h>
#include <stdlib.h>
#include <map>
#include <algorithm>
#include <math.h>        //round(double)
using namespace std;
double data[3][3];
double maxn;
map<int, char> mp;
void init(){
	mp[0] = 'W';                                //这里使为了练习map的用法,可用char数组代替
	mp[1] = 'T';
	mp[2] = 'L';
	fill(data[0], data[0] + 3 * 3, 0.0);        //这里是为了练习一下fill对二维数组的用法,可删去
}
int main(){
	init();
	double result = 1.0;
	int maxj;
	for (int i = 0; i < 3; i++){
		maxn = -1000.0;
		for (int j = 0; j < 3; j++){
			scanf("%lf", &data[i][j]);
			if (data[i][j]>maxn){	// 找到每一场比赛的最高赔率是买什么
				maxn = data[i][j];
				maxj = j;
			}
		}
		result *= maxn;
		printf("%c ", mp[maxj]);
	}
	result = (result*0.65 - 1) * 2;
	printf("%.2f\n", round(result * 100) / 100);
	return 0;
}

Analysis

-世界杯来啦!已知三场比赛胜、平、负的信息(一行代表一场比赛)。

-求对于三场比赛,怎么买才能获得最大利益(最大利益=(第一场买的赔率 * 第二场买的赔率 * 第三场买的赔率-1)* 2,保留两位小数)。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103748390