PAT 1011

1011 World Cup Betting (20分)


With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

一、试题分析:

  • 每一行:每个游戏对应一行数据
  • 每一列:三个游戏分别对应的结果W(胜利)、T(平局)、L(失败)
  • 求出最大的利润

二、解题思路:

  • 所有的输入数据直接用一个二维数组存储即可
  • 将每一个游戏赌注的最大值存储到max数组中
  • 并将对应的结果的下标值记录到index数组中
  • 根据gameid数组及上述index数组输出对应的结果字符
  • 按照题目所给公式求出最大利润:(\prod(每一个游戏的赌注)* 0.65 -1)*2 
  • 根据题目要求:利润输出注意保留两位小数
#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
    double game[3][3]={0}; //存储所有输入数据
    double max[3]={0};
    char gameid[3]={'W','T','L'};
    int index[3]; //记录选择的gameid对应的下标

    for(int i=0;i<3;i++){
        for(int j=0;j<3;j++){
            cin>>game[i][j];
            if(game[i][j]>max[i]){ //找到每场游戏的最大利润
                max[i]=game[i][j];
                index[i]=j;
            }
        }
    }
    cout<<gameid[index[0]]<<' '<<gameid[index[1]]<<' '<<gameid[index[2]]<<' ';
    cout<<setiosflags(ios::fixed)<<setprecision(2)<<(max[0]*max[1]*max[2]*0.65-1)*2; //保留两位小数
    return 0;
}
发布了28 篇原创文章 · 获赞 2 · 访问量 6560

猜你喜欢

转载自blog.csdn.net/Ariel_x/article/details/104055062