PAT A1011 World Cup Betting

前言

传送门

正文

题目描述

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

解题思路:

还是那句话,其实在数据读入的过程中就能进行很多操作;这里有个常用的小技巧,就是用字符数组保存比赛结果,然后通过下标随机访问便能得到比赛结果。通过双重循环,遍历每一行,找到每一行中最大的那个数字,将其下标的对应的比赛结果输出,同时累乘n,最后按照公式输出(n*0.65-1)*2即可

参考题解:

#include<cstdio>
char flag[3]={'W','T','L'};
int main(){
	double n=1;
	for(int i=0;i<3;i++){
		double max=0,k;
		int m; 
		for(int j=0;j<3;j++){
			scanf("%lf",&k);
			if(k>max){
				max=k;
				m=j;
			}
		}
		n*=max;
		printf("%c ",flag[m]);
	}
	printf("%.2f",(n*0.65-1)*2);
	return 0;
}

后记

坚持

发布了65 篇原创文章 · 获赞 101 · 访问量 9万+

猜你喜欢

转载自blog.csdn.net/qq_40563761/article/details/102953674
今日推荐